Adventist Health Clinical Information Systems

Discern Analytics 2

Learning Solutions
Contents

Introduction: ............................................................................................................................................. 1
Key Concepts: ........................................................................................................................................... 1
Logging in to DA2 .................................................................................................................................... 2
Opening the Query Builder ........................................................................................................................... 4
Selecting the Query Columns ....................................................................................................................... 4
Building a Query ....................................................................................................................................... 5
Setting a Query Timeout ............................................................................................................................. 9
Saving a Query ......................................................................................................................................... 10
Runtime Prompts ...................................................................................................................................... 11
Managing Runtime Prompts ................................................................................................................... 12
Running a Query Preview .......................................................................................................................... 14
Running a Query in the Viewer .................................................................................................................. 16
Running Reports using Report Navigator ................................................................................................. 18
Running Reports .................................................................................................................................... 18
Saving a Report Run for Later Use ........................................................................................................... 21
Opening a Saved Document ...................................................................................................................... 21
Scheduling a Report ................................................................................................................................ 22
Exporting a Report .................................................................................................................................. 25
Discern Reporting Portal ............................................................................................................................ 26
    Settings: ............................................................................................................................................ 27
    All Reports Tab: ................................................................................................................................. 27
    My Favorites Tab: ............................................................................................................................... 28
    Report Running Options: .................................................................................................................. 28
    Applications: ..................................................................................................................................... 30
Introduction:
This guidebook is intended to help end-users create and run reports in Discern Analytics 2.

Key Concepts:

Discern Analytics 2.0 - Discern Analytics 2.0 (DA2) is the primary reporting tool for Cerner Millennium. DA2 allows report-designers to create sophisticated reports that can be exported to excel, calculate graphs or metrics, and email documents to system users.

Document - In DA2, once a report has been run with given parameters, it is stored as a Document which is available either temporarily for viewing or can be saved to be opened quickly in the future without re-running the report.

Explorer Menu - Explorer Menu is a folder-driven tool that allows users to run pre-programmed reports to the screen or a printer. Once run, reports can be printed or, in some cases, saved to a folder for retrieval at a later date. Eventually, all reports available in Explorer Menu will be migrated to DA2, the preferred reporting solution.

Menus/Folders - All of the Cerner reporting tools are organized through folders, also called menus. Expand a folder by double-clicking the folder or clicking once on the plus sign to the left of the folder. Expanding a folder may reveal reports (programs) or additional folders which can be expanded.

Report - A report is a program that is available for a user to run, to extract information to the screen.
Logging in to DA2

**Option 1:**

- From your group applications, **Click**

- From the Cerner Millennium log-in window, enter your Adventist Health username (sometimes called your “6-1-1”) and password.

- **Click OK.**

**Option 2:**

- From your group applications, **Click**

**NOTE:** If you need to access Explorer Menu or Discern Reporting Portal you would click on this icon as well.
From the Cerner Millennium log-in window, enter your Adventist Health username (sometimes called your “6-1-1”) and password.

Click OK.

Select Discern Analytics 2.0

Option 3:

If you are already working in PowerChart, you can access the DA2 application from there as well, simply click on the **DA2 icon** and sign in.
Discern Analytics 2 (DA2)

Discern Analytics 2.0 has two tabs, Domains and Reports. The Domains tab contains the Business Domains that are used to create queries. The selection of Business Domains visible to you is determined by what metadata has been imported into the system and by your personal security settings. If the Domains tab is not displayed, from the Window menu, select Show View > Domains.

To find the domain you want in a large list, enter a portion of the domain name in the Search box. In order to build a query, you must participate in at least one owner group, and report-on permission for the Business Domain in Discern Administrator.

Double-click the domain to open the Query Builder.

Opening the Query Builder

The following are components of business domain in Discern Analytics 2.0.

<table>
<thead>
<tr>
<th>Key</th>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Category</td>
<td>Logical grouping of columns within the domain.</td>
</tr>
<tr>
<td>2</td>
<td>Fact</td>
<td>Columns that contain aggregated data such as counts or sums.</td>
</tr>
<tr>
<td>3</td>
<td>Dimension Columns</td>
<td>Contain descriptive information such as name, type or date.</td>
</tr>
<tr>
<td>4</td>
<td>Query tab</td>
<td>The tab that contains the current query.</td>
</tr>
</tbody>
</table>

Selecting the Query Columns

The domain displays the columns of information that you can use to build the query. The domain contents are structured in folders you can expand to see available columns. These folders are known as Categories and are used to organize the information. The domain looks different depending on the underlying metadata. You can expand or collapse columns by clicking the triangle next to the Category.

To build a query, move the columns you want into the Selected Columns window. To locate a specific column, enter a portion of its name in the Search box. You can move individual columns either by using the arrow keys or by dragging the column to the Selected Columns window. To select multiple columns at once, press SHIFT or CTRL and click the columns you want.
Building a Query:

- When you first start DA2, two tabs should be present:
- If the Reports tab or Domain are not present, select **Window > Show View** and Reports or Domains.

**Step 1** To build a query **double-click** the business domain.
Step 2  When the query builder opens, the content of the domain is displayed on the right side. The domain contains folder structures that can be expanded to expose the available columns.

Step 3  To start building the query:

1. Move the columns to the selected columns window by either dragging and dropping or by the arrow keys or press SHIFT or CTRL to multi-select.
2. Be sure to always have at least one Qualification selected. Qualification are used to restrict the amount of data returned by the query.
3. Columns with a red indicator cannot be used.
Step 4

1. Different Types of qualifications are available. Select Filter List from the drop down arrow.

2. Click Modify Filter List.
**Step 5**  You will then fill out the Admit Dt/Tm filters for the dates you want. Once you are done click the **Close** button.

**Step 6**  The qualification with the filters are listed now.
Setting a Query Timeout

When a query runs, it searches tables in the database. It is possible to build queries that are not optimal and take a long time to run. As you develop queries, it’s a good idea to build in a safeguard against these mistakes. The best safeguard against long-running reports is to set a time out.

Complete the following steps to set a query timeout:

**Step 1**
Click the General tab.

**Step 2**
Enter the maximum number of seconds you want the query to run in the Query Timeout Field. The query stops if the timeout threshold is reached and no data is returned.
Saving a Query

To save a Query you have created:

**Step 1**
Click **File** and **Save As**.

**Step 2**
Enter a name to identify the query and click **OK**.

**NOTE**: Once the query is saved, it is listed under the Domain from which it was built. If you don’t see it, press F5 to refresh the domain view. Make sure you removed any text in the search box, which could be filtering your query.
To view queries built from a domain, select the triangle to the left of the name to expand the Business Domain, then click on the saved query.

Runtime Prompts
Runtime prompts allow you to select values that are used to filter your query at the time the report or query runs. The filter list provides a static list of values that will remain constant each time the query is run.

To add a runtime prompt query, follow the steps below:

**Step 1**
In the query tab, select **Runtime Prompt** from the qualification drop-down. The Runtime prompt is added to the query.
Discern Analytics 2 (DA2)

**Step 2**
The runtime prompt must be associated with a prompt name. To assign a name to the prompt, **click** the ellipses button to add a new runtime prompt. This associates the prompt with the name of the column.

![Qualifications](image1)

**Step 3**
Click **OK**. The prompt you selected is added to the query.

![Select Runtime Prompt](image2)

When the query is run, the name of the prompt will be seen in the prompt dialogue.

**Managing Runtime Prompts**
Runtime prompt names used in a query are managed in the query’s Query List tab.

Complete the following steps to change the name of a runtime prompt.

**Step 1**
1. Click the **Query List** tab.
2. **Select** the runtime prompt you want to rename.
3. **Click Rename**. The Rename Runtime Prompt Dialog box is Displayed.
Step 2  Enter the new name for the Runtime Prompt and click OK.

Step 3  The new name assigned to the prompt is displayed in the Runtime Prompts box.
Running a Query Preview

Step 1
From the domain, right click on the Query and select Run Query Preview.

Step 2
Enter any run-time prompts if necessary and click OK when finished.
Step 3  The preview report will take a couple seconds to gather the results.

Step 4  The Query Preview Report will then appear. Click OK to exit the window after previewing it.
Running a Query in the Viewer

To run the query results in the Viewer, follow the steps below:

**Step 1**
1. Click the **Domains** tab in the main window.
2. **Click** the arrow next to a domain to display queries available in that domain or type the query name in the box at the top of the domains tab to search for it.

**Step 2**
Right-click the query name and select **Run Query** in Viewer.
Step 3  The system displays the query in the Report Viewer window.

With the result in the Viewer, you have options for exporting the data to CSV or into other formats such as Excel, PDF, Word, or you can print the results. You can also change the prompts and re-run the query.

- **Viewer Tab**
- **Change Runtime Prompts**
- **Report Navigation**

- **Export data** - Allows you to export results to CSV.
- **Export data** - Provides ability to export report to output to Excel, PDF, Word, etc.
- **Print Report**
Running Reports using Report Navigator

The reports tab contains the folders and reports available to you. If the reports tab is not displayed, from the Window menu, select **Show View > Reports**. Reports are divided into published and personal folders. You can display Recent Reports by setting a preference. Different types of reports are indicated by different icons.

Running Reports

**Step 1**  
Click the Reports tab in the main window. The system displays the folders in the reporting system.

**Step 2**  
Double-click or click the arrow next to the folder name under **Published Reports** to expand it. The system displays the reports saved in that folder.
Step 3 **Right-click a report name and select Run Report.**

![Image of right-click menu with Run Report highlighted]

Step 4 **If the report contains runtime prompts or report parameters, select the values that you want from the list and click OK.**

![Image of parameter selection window]
Step 5

When the report has completed, the results are displayed in the Report Viewer window. The toolbar at the top of the window has options to view the table of contents, run the report again with different values, export data, save a document, export the report to various formats (Excel, Postscript, PDF, Word, PowerPoint, and OpenOffice formats), and print the report.
Saving a Report Run for Later Use

**Step 1**
Click **Save Document** in the Viewer.

**Step 2**
Enter the **Document Name** and select the **Document Type**. Click **OK**.

Opening a Saved Document

**Step 1**
To view a saved document in **Discern Analytics 2.0**, right-click the report and select one of the following:

- **View Document – Select Document**: Presents a list of documents that have been saved for the report. Select the document you want from the list to open it in the Viewer.

**NOTE**: The document is rendered in the format in which it was stored.
Scheduling a Report

Report Scheduling options differ based on the type of report being scheduled. This is similar to the different viewing options for different report types. For this scenario, a DA2 report is used to demonstrate the full range of scheduling options. Also, note that by default, a scheduled report creates a document which must be retrieved within 7 days. After that a purge job will delete the document.

Complete the following steps to schedule a report:

**Step 1**
1. Right click the report
2. Select **Schedule> New Schedule**

   - **Run Immediately** - this option allows the user to run the report in the background and save it as a document in DA2 and/or as a file on the network.

   - **New Schedule** - this option allows the user to schedule a report to run and save a document at a given time of day.

   - **View Existing** - this option allows the user to view, edit, and delete existing schedules for reports. A scheduled report should never be deleted if it was not created by you.

**Step 2**
Select **Create a New Schedule**, click **Next**.
Step 3

Define the name of the schedule and the frequency to be run, click **Next**.

![Schedule configuration screen](image)

Step 4

Complete the Batch Details to describe the report leaving the default display type that auto-populates. Report parameters can remain empty for the DA2 report.

1. **Click** the check box next to *Save document to database* and view the report at a later date without re-selecting prompts.
2. **Click** **Next** to move to the Prompts screen.
Step 5 Complete the prompts (assuming all prompts are required). If the schedule is recurring, relative dates should be used to make sure the report is relevant each time it is run automatically and click Finish. The report will then run at the specified time and frequency.

Step 6 To reopen the document, right-click the report, select View Document> Select Document.
Exporting a Report

**Step 1** From the Report View tab, select the Export Report icon.

**Step 2** Confirm Export Format is Excel, click OK.
Discern Reporting Portal
All reports available through Explorer Menu and Discern Analytics 2 are now available in one application, the Discern Reporting Portal.
Settings:

Within Settings the following defaults can be adjusted:

- Number of recent reports to show
- Number of reports to show per page
- Select organizations

Report search field allows you to search for specific reports.

All Reports Tab:

NOTE: Show OMF Saved Views is the option that allows old DA reports to be visible within the Portal. If you would like this option be sure to click in the box.
My Favorites Tab:

**Step 1** To add reports to and from the My Favorites tab, click the star in the far right column of the report display.

**Step 2** The star turns yellow to indicate that it has been added to My Favorites. Click the star again to remove a report from My Favorites, and the star is no longer yellow and that report will disappear from the Favorites Tab.

Report Running Options:

3 Options:

1. Run Report - This will run the report. The view will change to a report running screen and any run time prompts will appear.
2. Run Report in Background - This is the same functionality that exists in DA2 that is called ‘Schedule Run Immediately’

- Scheduling wizard will appear

After all data and prompts are filled out, the report will start running in the background.

3. The data will be viewable in by selecting the ‘View Previous Run’ button on the main screen.
Applications:

When the drop down menu is selected, links to either DA2 or Explorer Menu are available for an easier transition from within the Discern Reporting Portal.